BioFuels Technologies Forum  

Go Back   BioFuels Technologies Forum > DODGE CUMMINS / HEAVY DUTY > 3rd Gen Cummins 03-07 Common Rail

Thread Tools Display Modes
Old 07-25-2017, 10:11 PM
Alex Keith Alex Keith is offline
Newbie VegiRamer
Join Date: Jun 2014
Location: Lethbridge, Alberta
MacGyver Rating: DC Welder
Posts: 18
Default WVO taking out injectors

Hi folks

About a month ago, injectors 1 and 6 were showing signs of wear, so I had all six injectors replaced. After running the new set on diesel for about a week, started running on WVO again, including daily commute and three road trips. This past weekend, truck threw engine code P0148 and noticed white smoke at the tailpipe plus clacking noise under the hood. Today, the truck is back in the shop and the verdict is injectors 1 and 6 are shot again.

Here's the background

Been running the truck on WVO for several years now. Started with PlantDrive kit then happily upgraded to the VegiRam. Last December we ran out of WVO so just drove on diesel for about 4 months. When I started running on WVO again, the return flow valve stuck and I wound up with WVO in the diesel tank. Took the VegiRam manifold apart, cleaned everything up, new pressure switch and new filter. All good. Fuel was going where it was supposed to. Then had injectors replaced and the rest you know. At the time, truck was throwing code P0148 and the engine would stutter when going downhill with cruise control on at highway speed.

What am I missing here? Everything is flowing where it's supposed to and the CP3 is protected by either the stock filter on diesel or the VegiRam filter on WVO. And why is it only taking out 1 and 6?

Any help would be much appreciated. My diesel mechanic knows his stuff but WVO is all new to him. Obviously I can't afford trial and error with these injectors. Thanks
2006 Dodge Ram 2500 5.9L 6 speed quad cab
Reply With Quote
Old 07-28-2017, 10:58 PM
N2GN2's Avatar
N2GN2 N2GN2 is offline
Big Sky Country
Join Date: Nov 2011
Location: Montana
Miles on Grease: 65,500
MacGyver Rating: 6
Posts: 1,680

Take the injectors apart and find out why they are "failing".
2006 F-350 King Ranch Crew Cab Long Box 4x4
2001 Excursion Limited 4x4
2000 F-350 Lariat Crew Cab Long Box 4x4 ZF6, V4 March 2013
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT. The time now is 10:36 AM.

Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.