BioFuels Technologies Forum  

Go Back   BioFuels Technologies Forum > FORD SUPER DUTY / HEAVY DUTY DIESEL > 94-97 7.3

Reply
 
Thread Tools Display Modes
  #11  
Old 07-22-2015, 01:20 AM
AzDave AzDave is offline
BFT Dealer
 
Join Date: Sep 2008
Location: Mayer, Arizona
Miles on Grease: 50,000
$ Estimated Saved: Over$10,000
MacGyver Rating: .8
Posts: 1,562
Default

I sent him photos , options and questions on what he needs from Veggiegarage. Looks easy with the turbo removed. Easy to get to the Fuel pump and Fuel filter housing for removal without bending over hood as long.
__________________
95 Dodge Ram. Running on Recycled Vegetable Oil since 5-07. Sold.. 96 Ford F250 System in progress. 2-16 Sold 2001 F350 System in progress. www.Veggiegarage.com Owner www.Veggiegarage.com
Reply With Quote
  #12  
Old 08-14-2015, 02:01 AM
heffen heffen is offline
Newbie Vegistroker
 
Join Date: Jun 2015
Posts: 8
Default Need Advice

So, I've been learning a lot about 7.3's and their problems, because I have them. I want to get the E-fuel kit soon, but I feel like I should try to fix some of my issues first. Once again these are non-veg issues, and you can tell me to stop asking at any time, but this community has been very supportive and helpful so I'm asking again.

I Still have no boost and here is what I've done (Keep in mind: 1st diesel)

Complete turbo rebuild with ebpv delete

modified air intake with 2 no oil cone filters and crankcase vent reroute to minimize oil mist

replaced icp

replaced ebp sensor and tube

checked map tube

replaced map sensor

checked for exhaust leaks: fixed most, still some at manifold to up pipes but very small

If I disconnect the map sensor I get some boost and it seems to run better in general. Idle is consistent and not rough From scouring forums of other peoples problems I'm at a loss. Maybe a bad wiring harness?

Any suggestions would be appreciated.

Thanks Again and Again
Heffen
__________________
'97 E450 Ambulance
Reply With Quote
  #13  
Old 08-14-2015, 12:23 PM
skyskijason's Avatar
skyskijason skyskijason is offline
Gettin Greasy
 
Join Date: Aug 2008
Location: N. Georgia
Miles on Grease: 330,000
$ Estimated Saved: at least a little
MacGyver Rating: 1.5
Posts: 4,518
Default

How are you measuring boost?

Have you hooked up a scan tool and checked other parameters yet?

Any codes?

Nobody here will tell you to stop asking questions.
__________________
2001 F350 XLT 4x4, dually flatbed. 6637 air filter, single-shot injectors, straight-piped, BTS tunes, 200 gal main VO tank - 180k greasy miles
2000 Excursion Limited 4x4. V3, AIS intake, BTS trans & tunes - 120k VO miles
veggiegarage.com authorized installer

RIP X & Toyhauler - you served us well.
Reply With Quote
  #14  
Old 08-14-2015, 02:46 PM
heffen heffen is offline
Newbie Vegistroker
 
Join Date: Jun 2015
Posts: 8
Default

I am using a scangauge ii

no codes even with the map unplugged

ebp 15 at idle

icp 500 at idle

ipr 10.5 at idle
__________________
'97 E450 Ambulance
Reply With Quote
  #15  
Old 08-14-2015, 07:35 PM
AzDave AzDave is offline
BFT Dealer
 
Join Date: Sep 2008
Location: Mayer, Arizona
Miles on Grease: 50,000
$ Estimated Saved: Over$10,000
MacGyver Rating: .8
Posts: 1,562
Default

Like Jason asked. How are you measuring boost?
__________________
95 Dodge Ram. Running on Recycled Vegetable Oil since 5-07. Sold.. 96 Ford F250 System in progress. 2-16 Sold 2001 F350 System in progress. www.Veggiegarage.com Owner www.Veggiegarage.com
Reply With Quote
  #16  
Old 08-15-2015, 01:19 PM
heffen heffen is offline
Newbie Vegistroker
 
Join Date: Jun 2015
Posts: 8
Default

i am using the scangauge to measure boost in psi

it reads a max of about 4 with the map sensor plugged in and around 10 when unplugged
__________________
'97 E450 Ambulance
Reply With Quote
  #17  
Old 08-15-2015, 02:43 PM
AzDave AzDave is offline
BFT Dealer
 
Join Date: Sep 2008
Location: Mayer, Arizona
Miles on Grease: 50,000
$ Estimated Saved: Over$10,000
MacGyver Rating: .8
Posts: 1,562
Default

The Scan Gauge reads boost thru the MAP Sensor. So it showing 10 psi when disconnected is confusing. Please rig up a gauge somehow to the hose that goes to the MAP sensor. Then you will see boost. My stock OBS only makes 10 to 14 or so pushing it. I read on a gauge T'd into the hose going to the Map sensor. Dave
__________________
95 Dodge Ram. Running on Recycled Vegetable Oil since 5-07. Sold.. 96 Ford F250 System in progress. 2-16 Sold 2001 F350 System in progress. www.Veggiegarage.com Owner www.Veggiegarage.com
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 11:13 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.