BioFuels Technologies Forum  

Go Back   BioFuels Technologies Forum > CHEW THE FAT > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 10-01-2019, 08:27 PM
TxFordGuy TxFordGuy is offline
Senior Vegistroker
 
Join Date: Oct 2011
Location: Bellville, TX
MacGyver Rating: 5
Posts: 327
Default V3 doesnt run long

Hey yall,

Been a while but still jump in to read from time to time. I had a pressure switch fail on me. Got it finally replaced but now my system only runs for about 10min of driving and then the light turns off. I don't have a pressure gauge but never had an issue before. Any insight?
__________________
2002 F-250 Lariat 4x4 CC, 4" Magnaflow SS Exhaust, Banks Ram-Air, DP-Tuner, Former BioD runner now Vegistroke V3
Reply With Quote
  #2  
Old 10-29-2019, 12:23 AM
Wyn-Wyn's Avatar
Wyn-Wyn Wyn-Wyn is offline
SubZero 7.3
 
Join Date: Feb 2013
Location: Sault Ste Marie , Ontario , Canada
Miles on Grease: 50000+
$ Estimated Saved: 14000
MacGyver Rating: 8
Posts: 339
Default

Could be many things. I definitely suggest first step is to get a pressure gauge. I would be lost without mine.
Reply With Quote
  #3  
Old 11-24-2019, 11:50 PM
Tampa450's Avatar
Tampa450 Tampa450 is offline
Gettin Greasy
 
Join Date: Sep 2008
Location: Wimauma FL
Miles on Grease: 250k+
$ Estimated Saved: priceless
MacGyver Rating: 6
Posts: 821
Default

Make sure your tank vent isn't clogged.
__________________
-Shawn Collister-
-02 F250 7.3 - SSB V3, AC's tuned by Swamps, AIS, 38R, 4" ex, DI tranny
-00 F350 7.3 - CC with no back seat
-Multiple trailers and a bunch of other junk
Straight outta Wimauma
Reply With Quote
  #4  
Old 11-25-2019, 04:56 AM
Fordnut74's Avatar
Fordnut74 Fordnut74 is offline
Mad scientist
 
Join Date: Aug 2008
Location: Good Question
Miles on Grease: 250,000
$ Estimated Saved: -45,000
MacGyver Rating: 8.5
Posts: 1,223
Default

Sounds like a plugged filter or prefilter to me. Pressure gage would help immensely. When was the last time you you changed your filter. Could also be a worn pump that when it warms up it can't maintain pressure. Answer back and we will get this worked out
__________________
1999 F-350 Lariat 7.3 385,000 miles and counting
2000 VW Jetta 2.0
1966 Jeep J-300 with EFI 351W
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 10:18 PM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.