BioFuels Technologies Forum  

Go Back   BioFuels Technologies Forum > FORD SUPER DUTY / HEAVY DUTY DIESEL > 99-03 7.3

Reply
 
Thread Tools Display Modes
  #21  
Old 09-18-2018, 10:12 PM
Hawaiian Diesel's Avatar
Hawaiian Diesel Hawaiian Diesel is offline
F350 & Excursion Greaser
 
Join Date: Aug 2008
Location: Kailua-Kona Hawaii
Miles on Grease: Plead the 5th
$ Estimated Saved: Plead the 5th
MacGyver Rating: .01
Posts: 1,542
Default

Did you ever get the gaskets I sent?
__________________
2001 Excursion, V3, TS Chip, Walker BTM.
2002 F350 Crew, V2, DP Tuner, Walker BTM.
Reply With Quote
  #22  
Old 10-27-2018, 07:17 PM
davidschaffer davidschaffer is offline
Gettin Greasy
 
Join Date: Dec 2010
Location: Northwestern, Mi.
Miles on Grease: 257,000
MacGyver Rating: 5+
Posts: 1,072
Default

Quote:
Originally Posted by Wyn-Wyn View Post
You said you have not tried pinching the return line to the fuel tank. That might be a simple thing to give a shot. I've seen that low pressure problem because of the purge valve as well even if it's not leaking around the valve or anyting
I just replaced my V3 with a brand new V4 and cannot get more then 18psi unless I pinch off the return line. Does this mean the new purge valve is bad?
Reply With Quote
  #23  
Old 10-28-2018, 10:41 PM
AzDave AzDave is offline
BFT Dealer
 
Join Date: Sep 2008
Location: Mayer, Arizona
Miles on Grease: 50,000
$ Estimated Saved: Over$10,000
MacGyver Rating: .8
Posts: 1,569
Default

If pinching the return to veg tank from the V3-4 allows fuel pressure to raise a lot then yes fuel is leaking thru Purge Valve. First electricly unplug the purge valve and retest first.
__________________
95 Dodge Ram. Running on Recycled Vegetable Oil since 5-07. Sold.. 96 Ford F250 System in progress. 2-16 Sold 2001 F350 System in progress.Sold www.Veggiegarage.com Owner www.AzFuels.com.com
Reply With Quote
  #24  
Old 10-29-2018, 04:19 PM
ourulz88's Avatar
ourulz88 ourulz88 is offline
Military Vegistroker
 
Join Date: Jun 2014
Location: Bremerton, WA
Miles on Grease: 50,000
$ Estimated Saved: 12,500
MacGyver Rating: 3
Posts: 75
Default

have you tried bumping up the pressure on the regulator? my friends 5.9L dodge with a V4 was having the same problem after he changed the prescreen and filter. we tried everything and could not get it to pressurize. jay recommended he bump the pressure up no more than 1/8th of a turn and it worked immediately like a champ and has been working flawlessly ever since. he was saying that sometimes the pressure will be just right at that cut off point for low pressure/auto on and will not turn on or will go back and forth.
__________________
2005 5.9l 2500 dodge ram, 6 speed, v4 kit
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 01:11 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.