BioFuels Technologies Forum  

Go Back   BioFuels Technologies Forum > FORD SUPER DUTY / HEAVY DUTY DIESEL > 99-05 Excursion

Reply
 
Thread Tools Display Modes
  #1  
Old 11-11-2017, 05:59 PM
Sherm169's Avatar
Sherm169 Sherm169 is offline
Vegistroker
 
Join Date: Jan 2010
Location: Fort Wayne, IN
Miles on Grease: 45,000
$ Estimated Saved: $7,500
MacGyver Rating: 6
Posts: 78
Send a message via Skype™ to Sherm169
Default Low Pressure, System On

Ok, so I have a very strange issue and need some insight.

I took a long trip in August (2400 miles towing a large trailer Woot Woot) all was well with the V3 system. I had used up much of my oil and had recently refilled my reserves so that I could use oil again.

I kick on my system onto auto when it is all warmed up and the pressure begins to fall, but it doesnt turn off! I am not sure where to begin to troubleshoot.

Why if the pressure switch reads low pressure would the system not shut down?

I am going to start with the prescreen and the pump. I have a fresh filter on it.

Any further insight would be a huge help.

thanks
__________________
'01 Excursion, 273K miles, 3" Lift, 32" tires, Goodyear Load Levers, DFA V3, TW Chip, straight 4" exhaust, AFE stage 2 intake, ISSPro gagues, TM Wastegate actuator w. BRV+, bucket seats need to be installed - 120,000 Miles on grease
Reply With Quote
  #2  
Old Yesterday, 07:38 PM
Longstroke Longstroke is offline
Senior Vegistroker
 
Join Date: Aug 2008
Location: East TN
Miles on Grease: 126,000
$ Estimated Saved: ??
MacGyver Rating: 5
Posts: 193
Default

Quote:
Originally Posted by Sherm169 View Post
Ok, so I have a very strange issue and need some insight.

I took a long trip in August (2400 miles towing a large trailer Woot Woot) all was well with the V3 system. I had used up much of my oil and had recently refilled my reserves so that I could use oil again.

I kick on my system onto auto when it is all warmed up and the pressure begins to fall, but it doesnt turn off! I am not sure where to begin to troubleshoot.

Why if the pressure switch reads low pressure would the system not shut down?

I am going to start with the prescreen and the pump. I have a fresh filter on it.

Any further insight would be a huge help.

thanks

Unplug your purge valve at the manifold and check your pressure to see if it goes back to normal.

I'm troubleshooting my V3 right now, when the green light comes on so does the purge valve so there's an issue with the board.
__________________
95 F250XL PSD SuperCab BTS auto , Gearhead Tuned, Vegistroke V3 , Tymar Intake, Stage 1's ADRENALINE HPOP. Absolute CF
Early 99 XLT SuperCab Auto, MBRP 4" Exhaust, DIY Tymar, Autometer Gauges.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT. The time now is 05:41 AM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.