BioFuels Technologies Forum  

Go Back   BioFuels Technologies Forum > Search Forums

Showing results 1 to 25 of 196
Search took 0.02 seconds.
Search: Posts Made By: brobrad
Forum: Technical Write-ups 08-01-2017, 10:05 PM
Replies: 80
Views: 20,923
Posted By brobrad
Pics

Yup, pics seem to be gone. ANYONE have them?
Forum: 99-03 7.3 03-31-2017, 07:46 PM
Replies: 8
Views: 1,377
Posted By brobrad
Resolved

Okay, I did figure out that the problem was no power coming into blade 5 on the rocker switch. The two blades that should have 12volts coming into them are from two different sources. Blade 5 is...
Forum: 99-03 7.3 03-28-2017, 12:40 PM
Replies: 8
Views: 1,377
Posted By brobrad
I have not. I've had other issues that I were...

I have not. I've had other issues that I were still more pressing. I got those resolved yesterday evening. I hopefully will have time over the weekend. I emailed BFT, but no answers as of yet....
Forum: 99-03 7.3 03-27-2017, 07:04 PM
Replies: 8
Views: 1,377
Posted By brobrad
bump- any help?

bump- any help?
Forum: 99-03 7.3 03-20-2017, 10:30 PM
Replies: 8
Views: 1,377
Posted By brobrad
Okay, I've made very little progress, but here's...

Okay, I've made very little progress, but here's what I have. the rocker switch is as follows:

dashes = pins on the rocker switch
> --- 7 (for some reason it won't let me...
Forum: 99-03 7.3 03-11-2017, 02:44 PM
Replies: 8
Views: 1,377
Posted By brobrad
I discovered that the harness had gotten against...

I discovered that the harness had gotten against the exhaust. It melted the plastic loom and the insulation off of a couple wires. The yellow wire was completely exposed. The green wire was...
Forum: 99-03 7.3 03-10-2017, 10:06 PM
Replies: 8
Views: 1,377
Posted By brobrad
As I said I have voltage to board/ fuse and relay...

As I said I have voltage to board/ fuse and relay are good. The "trig" wire does not have power when in manual on. Sounding like it might be my board????
Forum: 99-03 7.3 03-10-2017, 09:23 PM
Replies: 8
Views: 1,377
Posted By brobrad
No power To V3 Pump or Fuel gauge

I have a 2000 Excursion that I bought already converted. It has new pressure switches/purge solenoid/ temp switch and pump. It ran fine for a year or so after overhaul, but now I have no power to...
Forum: 99-05 Excursion 12-19-2016, 11:01 AM
Replies: 7
Views: 2,500
Posted By brobrad
V3 15 Amp Fuse Blown Again

I replaced a few other fuses under dash and hood the other day when my problems began. Both Batteries had gone bad so i replaced them as well. I assuming that all to be related. I replaced the ...
Forum: 99-05 Excursion 12-10-2016, 05:30 PM
Replies: 7
Views: 2,500
Posted By brobrad
Seems to have been fuses. My Heater blanket...

Seems to have been fuses. My Heater blanket relay Melted the holder and I lost a 15Amp fuse on my V3 controller. Maybe she's back up and going. I've gotta see of the blanket is good. I hope to do...
Forum: 99-05 Excursion 12-10-2016, 12:55 PM
Replies: 7
Views: 2,500
Posted By brobrad
Yes, I've read that before. I had a leak about a...

Yes, I've read that before. I had a leak about a year ago and fixed it. We have had some rain, but I Don't think it was leaking. I'll check it out though. I've still gotta check all the fuses...
Forum: 99-05 Excursion 12-08-2016, 10:47 PM
Replies: 7
Views: 2,500
Posted By brobrad
Checked under dash. Haven't been still long...

Checked under dash. Haven't been still long enough to check under the hood. BOth other vehicles are down right now.
Forum: 99-05 Excursion 12-08-2016, 08:34 PM
Replies: 7
Views: 2,500
Posted By brobrad
No purge/Run when Ignition OFF- other issues

If this is covered elsewhere please forgive me I've not had time to search. My 2000 V3 excursion has had a few issues lately. First, no Signal, flashers or brake lights. Long start when cool and...
Forum: 99-03 7.3 09-23-2016, 04:57 PM
Replies: 13
Views: 3,070
Posted By brobrad
I noticed the D2 rising and the WVO falling. I...

I noticed the D2 rising and the WVO falling. I got AZdave to ship me some of the stainless check valves and got them installed this morning. I was looking to all over and noticed two of the rubber...
Forum: General Discussion 04-02-2016, 08:31 PM
Replies: 3
Views: 1,164
Posted By brobrad
Thanks Dave, I looked it over. I think I can...

Thanks Dave, I looked it over. I think I can come up with something like that. I was trying to find a way around the 3 way valve, but no can do. I am curious about the pump you referred to for the...
Forum: General Discussion 04-01-2016, 02:03 AM
Replies: 3
Views: 1,164
Posted By brobrad
Recommended WVO setup P-pumped 12v

I used Dave's 3 valve setup on my 4bt for a veggie conversion with a FASS pump internally regulated. Though I love the powerstrokes, circumstances have presented an opportunity to do a Fummins...
Forum: EMERGENCY FORUM 11-11-2015, 04:05 PM
Replies: 6
Views: 3,336
Posted By brobrad
Mine was leaking (on vacation hundreds of miles...

Mine was leaking (on vacation hundreds of miles from home on a saturday of course) from the hose that was the supply line from the V3. I found a napa open and a kind gentleman took me to have the...
Forum: MISC 11-11-2015, 03:19 PM
Replies: 9
Views: 2,899
Posted By brobrad
What's the Location?

What's the Location?
Forum: General Discussion 10-21-2015, 06:51 PM
Replies: 17
Views: 3,661
Posted By brobrad
Jason, it'd be real nice to just get it done...

Jason,
it'd be real nice to just get it done with check valves. If you get it all mapped out let me know. I've got the valves already, but it does take a lot of space to plumb it all in and wire it...
Forum: General Discussion 10-20-2015, 01:43 PM
Replies: 17
Views: 3,661
Posted By brobrad
I Don't think a cryo'ed shaft would have made any...

I Don't think a cryo'ed shaft would have made any difference in my circumstance. The pump mechanic said he could not hold the new shaft in his un-shielded hand and insert it into the rotary head. ...
Forum: General Discussion 10-15-2015, 04:39 AM
Replies: 17
Views: 3,661
Posted By brobrad
Your point is about the diesel not the WVO. I...

Your point is about the diesel not the WVO. I grenaded a VE pump on my 4bt with early switchover from D2 to WVO. I would suppose that the D2 would be warm from circulation, but that is definitely a...
Forum: General Discussion 10-14-2015, 09:38 PM
Replies: 17
Views: 3,661
Posted By brobrad
Here's my oldest son's ride. Its a 96 with a...

Here's my oldest son's ride. Its a 96 with a copied Skyski system for wvo on it. http://i1021.photobucket.com/albums/af336/thebrownlees/FFC04911-7C49-4F89-838A-8E69C44A68E2_zpst0xoy27q.jpg

Here's...
Forum: General Discussion 10-14-2015, 09:11 PM
Replies: 17
Views: 3,661
Posted By brobrad
thanks dave, It looks just like the setup on...

thanks dave,

It looks just like the setup on my 4bt Plumbing i got from you. I look forward to the plumbing diagrams. I've got it all done in color pencil, but i haven't studied the 7.3 IDI...
Forum: General Discussion 10-14-2015, 03:55 PM
Replies: 17
Views: 3,661
Posted By brobrad
Yeah, that's the problem i'm thinking through. ...

Yeah, that's the problem i'm thinking through. The return from injectors etc. Gotta make sure that's all right. I suppose putting a tee to the supply line would ensure i was looping back what i...
Forum: Trip Planner 10-08-2015, 02:06 PM
Replies: 8
Views: 2,108
Posted By brobrad
I'm with you on that. Any system that has not...

I'm with you on that. Any system that has not been run regularly will need to be cleaned and most likely some parts changed out. I bought an excursion with V3 that had not been used. I have...
Showing results 1 to 25 of 196

 
Forum Jump

All times are GMT. The time now is 11:18 PM.


Powered by vBulletin® Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.